• Welcome aboard!!


    Great looking Kar!!


    I have had my 66 Silver Frost Hipo GT black pony interior fastback since about 1986.


    -Fred-

    65 Koupe early San Jose Phoenician Yellow 4 speed
    66 GT Koupe Dearborn Blue 4 speed
    66 KGT San Jose fastback pony interior Silver Frost 4 speed
    64 Falcon sedan delivery 289 4 speed
    65 Ranchero 289 4 speed
    66 Corvette roadster 427/425 4 speed

  • Hi - hope everyone is staying safe and healthy!


    Where is the best place to post 'How To' questions about debugging electrical problems...specifically ignition circuit?


    I had been driving my Kar often and it was running great. Then one day the ignition system just stopped working...no solenoid click, nothing. The battery is fully charged.


    I'm hoping someone has had similar problems and maybe shared some things to look for as the Kulprit!


    Thanks!


    ps. I've been sitting on this issue for a couple of months now while dealing with the virus sheltering in place. I'm in the SF Bay Area.

  • The best place for this question is in Koncerns & Troubleshooting. I tried to move this one post but ended moving the entire thread so I moved it back.


    -Fred-

    65 Koupe early San Jose Phoenician Yellow 4 speed
    66 GT Koupe Dearborn Blue 4 speed
    66 KGT San Jose fastback pony interior Silver Frost 4 speed
    64 Falcon sedan delivery 289 4 speed
    65 Ranchero 289 4 speed
    66 Corvette roadster 427/425 4 speed

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!